Not connect the uavcan gui tool

I want to use uavcan gui tool through usb-can adapter. (uavcan v0)

I bought an adapter that supports CANable v2.0, is there a possibility that uavcan gui tool won’t support this?

I uploaded slcan firmware, but it does not connect to uavcan gui tool.
and i got the following error : Could not initialize UAVCAN node.SLCAN ACK timeout

The firmware used is GitHub - normaldotcom/canable2-fw .

The cangaroo (beta. CANable 2.0 support) guided by CANable is connected, and the cangaroo (legacy) is not connected.

The UAVCAN GUI Tool is no longer maintained. Please use the DroneCAN GUI Tool instead.

For the background, refer here: Cyphal vs. DroneCAN

I was looking at the site for the previous name UAVCAN v0 until now. Overview - UAVCAN

I found out thanks to you that there is a DroneCAN GUI Tool. I will refer to the changed site. Overview - DroneCAN


I used the DroneCAN GUI Tool and I still get the SLCAN ACK timeout error.

It was set as shown in the picture below.

The cangaroo (beta) has a good connection.

In addition, it seems to be connected to the Yukon.

(ARK CANnode = Node ID 120)

The first reason for using DroneCAN GUI tools is to view Data type ID faster than tools such as pcan-view and cangaroo.

pcan-veiw and cangaroo were provided only as CAN-ID, making it inconvenient to analyze data type ID and payload.

Is there a reason why the DroneCAN GUI Tool doesn’t connect?

1 Like

Same case. Do you have any good news?

The DroneCAN GUI Tool apparently doesn’t support this adapter. You should get in touch with the maintainers for the solution.

Not connected yet.

and I tried it on Linux.
USB device recognition is smooth, but there was no response at any baud rate.
SLCAN ACK timeout error still occurs.

Its seems to be a problem with the adapter :joy:. I will use a different adapter.