Yakut File-Server - Software Update Checker is Not Required

I’ve got the yakut -v file-server command to work once but now when I try to restart it again days later the command gets locked up on yakut.cmd.file_server: Software update checker is not required. The terminal window just freezes at this output message and nothing happens.

I’m running this on Windows 10 environment and it worked on two different PCs but only the first time I implemented the file-server.

Anyone have any help on this? Thank you!

I think you forgot to say --update-software.

That got me past that issue. Now when I try to run the cmd 46 begin_software_update it timesout waiting for a response from node 46.

I guess the node didn’t respond.

Can I reset the node?


Great. How do I reset a node or node 46 so I can use the file-server again? Thank you!

Maybe try this:

y cmd 46 factory_reset
y cmd 46 restart

It is hard to provide more meaningful answers without having more details about your application.

Hi Pavel, I’m new to using Yakut and troubleshooting a working process for my environment.

When I try to factory_reset cmd 46 or any other node IDs they all timeout. I’ve tried to uninstall/re-install Yakut and recompile the Cyphal DSDL but get the same results.

Running the file-server --update-software command it is now locked up on “Initializing the node tracker”

Is there something I need to factory reset?

This means that either your node does not support the uavcan.node.ExecuteCommand RPC-service, which would be uncommon, or it has a different node-ID (not 46). You can try yakut monitor to see what nodes are online.

It’s not locked up. It means that it is running normally.

Thank you for the help Pavel! Everything is working correctly now.