uavcan.register.List problem

I’ve been fighting yukon for a day now. When requesting yukon uavcan.register.List constantly outputs 0 in index quality. on uavcan.register.I answer List correctly and even in the "Registers " column a line with the name of the register appears under the index 0. But at the same time in in get_register_names, in the line

response = await,

resopnse == None… This is very strange, sometimes it works correctly on restart, sometimes (most often) it doesn’t… uavcan.register.Access on my side is implemented correctly and also gives correct answers. I use can interface(kvaser:0)…

What could be the problem?? :grimacing:

Can you please test your implementation using Yakut instead of Yukon? The commands you need are register-list and register-batch, more on this in the README

I tried Yakut. But the reaction is still ambiguous. Although based on the CAN traffic, the response to the request is correct. It’s very strange, but I tried to request a sheet for about an hour, and after a while the request just started working. After the reboot , it stopped again . I have recorded the CAN log number. Reg Name “TEST1”

Based on your log, the response doesn’t have the correct transfer-ID in it. This explains why sometimes it works correctly – when your transfer-ID happens to match that of Yakut.

Omg :roll_eyes: …I probably didn’t read the documentation well… should the transfer-ID of the request match the transfer-ID of the response?? Thank you so much for your help.