Error in Pyuavcan Demo

Hey guys, I am new to all this and I am trying my best to learn by going through tutorials but I ran into an error when following along with the Pyuavcan Demo. I am using windows PowerShell, and python 3.9 and this error happened when I was trying to run Demo_app can someone help explain why this error appeared?

My end goal by learning all this is to develop a way of daisy chaining multiple Pixhawks through CAN Bus for a project of mine, if you have any insight or tips on this that would be greatly appreciated!

Hi Alan,

This is the intended behavior of the demo. The very next sentences say:

If you just run the script as-is, you will notice that it fails with an error referring to some missing registers.

So the application fails with an error that says that it doesn’t know how to reach the UAVCAN network it is supposed to be part of because there are no registers to read that information from. We can resolve this by passing the correct register values via environment variables

Hey Pavel,

Thanks for the response and sorry I should have been a little more specific but I did input the correct register values via environment variables, how they say to in the demo but I still got the same error?

Can you please share the CLI dump here?

Yes, so here is what I have been doing I state my register values and then run the demo app,

I think it’s a syntactic peculiarity of PowerShell. Try taking each value in double quotes:


It’s working! Thank you, I appreciate the help !